?

Log in

No account? Create an account
КОЛОКОЛА ГРОМКОГО БОЯ
("КГБ")
Вопрос к линуксоидам. 
29th-Apr-2008 07:51 pm
аватара
Не могу установить gtk+ - ругается на отсутствие зависимостей (glibc-2.0 >= 2.6.0, atk >= 1.0.1, pango >= 1.8.0), хотя упомянутые зависимости ручками были инсталлированы.

Дистрибутив Mandriva Free 2008, в официальных репозиториях на эту тему ни шиша нет.
Комментарии 
29th-Apr-2008 03:30 pm (UTC)
gtk из сорцов собирается?
29th-Apr-2008 04:01 pm (UTC)
Да.

Ошибка возникает на этапе выполнения команды ./configure и формулируется так:

checking for BASE_DEPENDENCIES_LIBS...
configure: error: Package requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the BASE_DEPENDENCIES_CFLAGS and BASE_DEPENDENCIES_LIBS environment variables
to avoid the need to call pkg-config. See the pkg-config man page for
more details.
29th-Apr-2008 07:19 pm (UTC)
можешь показать результат комманд
yum search glib-2.0
yum search atk
yum search pango

может версия хитро записано, проглядел.

Немного не понял, из бинарников ставишь или компиляешь? Если второе, то, наверное, тебе нужны специальные -dev пакеты (не знаю как в мандриве, в дебиане они бы звались glib-dev pango-dev ).

30th-Apr-2008 12:43 am (UTC)
Могу.

yum: command not found

Компиляю.

Девелоперские пакеты у меня тоже есть, но, по утверждению разработчиков, они нафиг не нужны. А бинарников я не нашёл...
30th-Apr-2008 09:10 am (UTC)
А зачем из сорцов?
30th-Apr-2008 12:07 pm (UTC)
А я нигде не вижу подходящей RPM-ки с бинарником... :(
30th-Apr-2008 03:05 pm (UTC)
Mandriva 2008 carroll.cac.psu.edu/pub/linux/distributions/mandrakelinux/official/2008.1/i586/media/main/release/libgtk+2.0_0-devel-2.12.9-2mdv2008.1.i586.rpm
Mandriva 2008 carroll.cac.psu.edu/pub/linux/distributions/mandrakelinux/official/2008.0/i586/media/main/testing/libgtk+2.0_0-devel-2.12.1-2mdv2008.0.i586.rpm
Mandriva 2008 carroll.cac.psu.edu/pub/linux/distributions/mandrakelinux/official/2008.0/i586/media/main/updates/libgtk+2.0_0-devel-2.12.1-2.1mdv2008.0.i586.rpm
Mandriva 2008 carroll.cac.psu.edu/pub/linux/distributions/mandrakelinux/official/updates/2008.0/i586/media/main/updates/libgtk+2.0_0-devel-2.12.1-2.1mdv2008.0.i586.rpm
Mandriva 2008 carroll.cac.psu.edu/pub/linux/distributions/mandrakelinux/official/2008.0/i586/media/main/release/libgtk+2.0_0-devel-2.12.0-7mdv2008.0.i586.rpm
30th-Apr-2008 03:21 pm (UTC)
Они не ставятся: конфликтуют с моей glibc-2.0, удалить которую невозможно.
30th-Apr-2008 03:56 pm (UTC)
Как именно конфликтуют?
Я к чему. Один раз зарезолвить зависимости и работать с пакетами (в идеале через пакетный менеджер, который кстати для мандривы 2008 не yum, а urpmi, с графической оболочкой rpmdrake, доступной из Mandriva Control Center), чем собирать код из сорцов. Собирать код из сорцов стоит только если нет вообще в мире нужного пакета, или если речь идет о Gentoo.
30th-Apr-2008 03:58 pm (UTC)
* Лучше один раз зарезолвить...
1st-May-2008 01:45 am (UTC)
Я понимаю. Но rpmdrake при попытке зарезольвить связи как раз и ссылается на нерабочий glibc 2.0, а удалить его не даёт без объяснения причины.
Выпуск подгружен %mon%